Написать программу которая про суммирует все 2ух значные числа содержащие 1

0 голосов
48 просмотров

Написать программу которая про суммирует все 2ух значные числа содержащие 1


Информатика (16 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

var a,a1,a2,sum,n,i:integer;

begin

readln (n);

for i:=1 to n do

begin

readln (a);

a1:=a div 10;

a2:=a mod 10;

if (a1=1) or (a2=1) then sum:=sum+a;

end;

writeln (sum);

end.

 

(666 баллов)