Напишите программу ** языке Pascal, которая с помощью цикла for to считала...

0 голосов
19 просмотров

Напишите программу на языке Pascal, которая с помощью цикла for to считала s:=1-2+3-4+5-6+7-8+9-10....


Информатика (20 баллов) | 19 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var n,i,s:integer;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n do 
 if i mod 2 =0 then s:=s-i else s:=s+i;
writeln('s = ',s);
end.

Пример:
n = 10
s = -5

(194k баллов)
0 голосов

Var n,s,i:integer;
begin
  write('введите n ');
  readln(n);
  for i:=1 to n do if i mod 2 <> 0 then s:=s+i else s:=s-i;
  writeln('s = ',s);
end.

(13.9k баллов)
0

И у меня при n=10 получилось -5 )))

0

Видимо, мы написали правильную программу )))