Написать программу вычисления суммы: Sin x + Sin 2x + Sin 3x + ... + Sin nx

0 голосов
128 просмотров

Написать программу вычисления суммы:
Sin x + Sin 2x + Sin 3x + ... + Sin nx


Информатика (17 баллов) | 128 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var x:=ReadReal('x=');
  var s:=0.0;
  for var i:=1 to ReadInteger('n=') do s+=sin(i*x);
  Writeln('s=',s)
end.

Тестовое решение
x= 0.543
n= 15
s=2.79048740821036

(142k баллов)