Напишите программу, которая заменяет расширение у заданного имени файла. Входные данные...

0 голосов
939 просмотров

Напишите программу, которая заменяет расширение у заданного имени файла.

Входные данные
Первая строка содержит имя файла, которое нужно изменить. Во второй строке записано нужное расширение.

Выходные данные
Программа должна вывести изменённое имя файла с заданным расширением.

Примеры
входные данные
qwerty
exe
выходные данные
qwerty.exe
входные данные
qwetry.old.pas
html
выходные данные
qwetry.old.html


Информатика (15 баллов) | 939 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET v3.1 сборка 1219

Var
 s,sf:string;
begin
 readln(s);
 readln(sf);
 if pos('.',s)<>0 then
 delete(s,s.LastIndexOf('.')+2,length(s)-s.LastIndexOf('.'))
 else
 s+='.'; 
 writeln(concat(s,sf));
end.

Пример ввода:
point.simple.txt
pdf
Пример вывода:
point.simple.pdf

(38.6k баллов)