По блок-схеме составить программу в паскаль.

0 голосов
24 просмотров

По блок-схеме составить программу в паскаль.


image

Информатика (56 баллов) | 24 просмотров
Дан 1 ответ
0 голосов

Вот, собственно, решёние


image
(4.0k баллов)
0

var
a,b,c:real;

begin

writeln('Введите значение a,b');
readln(a,b);
if (a>0) and (b>0)
then
begin
a:=2*a+b ;
b:= sqr(b);
end
else
begin
abs(a);
abs(b);
end;
c:=a+b;
writeln('Значение a= ', a,', значение b= ',b,', значение c= ',c);

end.