Помогите составить программу по схеме в паскале.

0 голосов
24 просмотров

Помогите составить программу по схеме в паскале.


image

Информатика (56 баллов) | 24 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;
begin
writeln('Введите a и b:');
readln(a,b);
if (a>0)and(b>0)
 then begin a:=2*a+b; b:=b*b; end
 else begin a:=abs(a); b:=abs(b); end;
c:=a+b;
writeln('a = ',a,'  b = ',b,'  c = ',c);
end.

Пример:
Введите a и b:
-5 8
a = 5  b = 8  c = 13

(194k баллов)