Составьте программу, выводящую ** экран символ * 20 раз

0 голосов
82 просмотров

Составьте программу, выводящую на экран символ * 20 раз


Информатика (282 баллов) | 82 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
  Write('*'*20)
end.

(142k баллов)
0

А этот код еще короче и не требует ничего знать о циклах)))

0

Это точно))) Жалко, что наша школа не скоро придет такой культуре программирования. Но подвижки уже наблюдаются. И это радует!

0

Не обязательно сразу использовать все, что дает PascalABC.Net 3.1 - можно для начала взять только простейшие удобства: объявление var в блоках и в заголовке циклов, процедуру Print для вывода с пробелом, возможности Write выводить любые объекты целиком, возможность преобразовать число в строку путем конкатенации ( 'число в '+2*2+' тексте') и "размножение" строки путем умножения её на множитель.

0

Да и работа со случайными числами существенно облегчает код и восприятие кода

0

Да, но это требует уже дополнительного изучения.

0 голосов

Задание на умение использовать циклы. Так как мы знаем, сколько раз надо выполнить операцию, то разумнее использовать цикл for:

var i:integer;
begin
  for i:=1 to 20 do write('*');
end.

Вот и весь код.

(13.9k баллов)