Ребят решите задачи 1) Дан текст .Написать программу вставляющию после каждой запятой по...

0 голосов
35 просмотров

Ребят решите задачи
1) Дан текст .Написать программу вставляющию после каждой запятой по одному пробелу.
2)Дан текст ,слова в тексте разделены одним и несколькими пробелами.Написатт программу выводящию все слова в алфавитном порядке.


Информатика (101 баллов) | 35 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//Pascal ABC.NET v3.1 сборка 1172

//1

Var
 s:string;
 i:integer;
begin
 readln(s);
 while i begin
 inc(i);
 if s[i]=',' then insert(' ',s,i+1);
 end;
 writeln(s);
end.

Пример ввода:
Some,awesome,test,text,
Пример вывода:
Some, awesome, test, text, 

//2

Var
 s:string;
 i,k,j:integer;
 ars:array of string;
begin
 readln(s);
 setlength(ars,length(s));
 k:=0;
 for i:=1 to length(s) do
 begin
  if (s[i]=' ') and (s[i+1]<>' ') and (i<>length(s)) then inc(k) else  ars[k]:=ars[k]+s[i];
 end;
 for i:=0 to k-1 do
  for j:=i+1 to k do
   if LowerCase(ars[i])>LowerCase(ars[j]) then
   begin
    s:=ars[i];
    ars[i]:=ars[j];
    ars[j]:=s;
   end;
 for i:=0 to k do
 writeln(ars[i]);
 end.

Пример ввода:
Очень              много яков и антилоп
Пример вывода:
антилоп
и
много
Очень
яков

(38.6k баллов)
0 голосов

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var s:=ReadlnString('>');
  s:=s.Replace(',',', '); Writeln(s);
  Writeln(NewLine,'Список слов:');
  s.ToWords.OrderBy(x->x).Println(NewLine);
end.

Тестовый пример
> Это   мой,плохо форматированный,но зато мой текст!
Это   мой, плохо форматированный, но зато мой текст!

Список слов:
зато
мой
мой,
но
плохо
текст!
форматированный,
Это

(142k баллов)