Напишите программу, которая заполняет массив из N элементов в обратном порядке...

0 голосов
735 просмотров

Напишите программу, которая заполняет массив из N элементов в обратном порядке последовательными натуральными числами, начиная с последнего элемента, который должен быть равен X .

Входные данные
Входная строка содержит два целых числа: начальное значение X и размер массива N , разделённые пробелом. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести содержимое массива: убывающую последовательность из N последовательных натуральных чисел; последний элемент должен быть равен X . Программа - PYTHON !!!!!!!!!!!!!!!!!!!!! ТОЛЬКО PYTHON !!!!!!!!!!!!!!!!!!


Информатика (56 баллов) | 735 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Если правильно понял условие, то может быть так:

x,n = map(int,(input('input x,n ').split()))
a=[0]*n
print('input')
for i in range(n):
    a[i]= x-i
    print(a[i])
print('Output')
for i in range(n):
    print(a[i]+n-1)

Тестовое решение:
input x,n 10 5
input
10
9
8
7
6
Output
14
13
12
11
10



(13.9k баллов)