Написать программу в Паскале, массив который меняет 5 и 3 строку.

0 голосов
44 просмотров

Написать программу в Паскале, массив который меняет 5 и 3 строку.


Информатика (34 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const n=6; m=4;
var 
a:array[1..n,1..m] of integer;
i,j,c:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
  a[i,j]:=random(50);
  write(a[i,j]:4);
  end;
  writeln;
 end;
for j:=1 to m do
 begin
 c:=a[3,j]; a[3,j]:=a[5,j]; a[5,j]:=c;
 end;
writeln('Полученный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do write(a[i,j]:4);
 writeln;
 end;
end.

Пример:
Исходный массив:
  25   4  33  17
  19  23  42   9
  36  40   1  48
  21  44  13  18
  38  29   8   7
  24  13   5  13
Полученный массив:
  25   4  33  17
  19  23  42   9
  38  29   8   7
  21  44  13  18
  36  40   1  48
  24  13   5  13

(194k баллов)