Написать программу, которая будет вводить n чисел и находит наибольшее и выводит...

0 голосов
53 просмотров

Написать программу, которая будет вводить n чисел и находит наибольшее и выводит наибольшее на экран


Информатика (22 баллов) | 53 просмотров
Дан 1 ответ
0 голосов

Var 
  i, n, a, max: integer;
begin 
  write('Кол-во чисел = '); 
  readln(n); 
  for i := 1 to n do  
  begin   
    readln(a);   
    if (i = 1) or (a > max) then max := a; 
  end; 
  writeln('Max-число = ', max);
end.