Паскаль, ребятки? Кто тут гений информатики? Помогите, пожалуйста!!! Написать программу и...

0 голосов
43 просмотров

Паскаль, ребятки? Кто тут гений информатики? Помогите, пожалуйста!!! Написать программу и блок-схему
Дан массив из 10 целых чисел, заполненный генератором случайных чисел. Найти минимальный элемент в массиве и подсчитать количество таких элементов в массиве.


Информатика (19 баллов) | 43 просмотров
0

слишком просто для гениев

Дан 1 ответ
0 голосов

Program p12;
type tab=array[1..10] of integer;
var t:tab;
i,k,min:integer;
begin
min:=100;
for i:=1 to 10 do
t[i]:=random(10);
for i:=1 to 10 do
if(t[i]for i:=1 to 10 do
if(t[i]=min) then k:=k+1;
write('массив: ');
for i:=1 to 10 do
write(t[i],' ');
writeln;
writeln('Меньшее число ',min);
write('Количество меньших чисел ',k);
end.

(346 баллов)