Составить программу вывода ** экран квадратов и кубов нечетных чисел от 13 до 48

0 голосов
61 просмотров

Составить программу вывода на экран квадратов и кубов нечетных чисел от 13 до 48


Информатика (12 баллов) | 61 просмотров
Дан 1 ответ
0 голосов

Var
  i : integer;
begin
  for i := 13 to 47 do
    if i mod 2 = 1 then
      write(i : 5, ' ');
  writeln;

  for i := 13 to 47 do
    if i mod 2 = 1 then
      write(i*i : 5, ' ');
  writeln;
  
  for i := 13 to 47 do
    if i mod 2 = 1 then
      write(i*i*i : 5, ' ');
end.

(918 баллов)