Напишите программу в паскале, вычисляющую НОД для 5 чисел (12,24,30,36,48)

0 голосов
199 просмотров

Напишите программу в паскале, вычисляющую НОД для 5 чисел (12,24,30,36,48)


Информатика (175 баллов) | 199 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET v3.1 сборка 1219

function nod(a, b:integer):integer;
 begin
  while a*b<>0 do
    if a>b  then
     a:=a mod b
     else b:=b mod a; 
  nod:=a+b;
 end;

 begin
writeln(nod(12,nod(24,nod(30,nod(36,48)))));
end.

Вывод: 6

(38.6k баллов)