Найти, есть ли данное число в массиве? Составить программу в с++

0 голосов
44 просмотров

Найти, есть ли данное число в массиве?
Составить программу в с++


Информатика (178 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
#include
using namespace std;

int main()
{
vector v;
cout <<"Укажите размер массива: ";<br> int s;
cin >>s;
srand(time(0));
for(int i=0; i!=s; ++i)
v.push_back(rand()%100);
int find;
cout <<"Введите число для поиска: ";<br> cin >>find;
bool founded = false;
for(auto it=v.begin(); it!=v.end(); ++it)
if(*it==find) founded=true;
if(founded)
cout <<"Это число есть в массиве!" <<endl;<br> else cout <<"Такого числа нет в мвссиве!" <<endl;<br>
return 0;
}

(1.7k баллов)