Нужно составить программу через процедуру в паскаль : Каждая бактерия делится ** две в...

0 голосов
81 просмотров

Нужно составить программу через процедуру в паскаль :

Каждая бактерия делится на две в течение одной минуты. В начальный момент имеется одна бактерия. Составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени.

Через procedure
:(


Информатика (5.3k баллов) | 81 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Procedure copy_bacterium(time:integer);
var
i, bacterium:integer;

    begin
    bacterium:= 1;
    for i:=1 to time do
        bacterium:= bacterium * 2;
    writeln(bacterium);
    end;
var
n:integer;
begin
readln(n);
copy_bacterium(n);
end.    

(2.2k баллов)