Напишите программу, которая вводит натуральное число N и выводит ** экран чётные...

0 голосов
564 просмотров

Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем N , в порядке убывания.

Входные данные:
Входная строка содержит одно натуральное число N .

Выходные данные:
Программа должна вывести в одну строчку через пробел чётные положительные степени числа 2, не большие, чем N , в порядке убывания. Если таких нет, программа должна вывести число 0.


Информатика (20 баллов) | 564 просмотров
0

Примеры:Входные данные1025Выходные данные1024 256 64 16 4

0

Входные данные3Выходные данные0

Дано ответов: 2
0 голосов
Правильный ответ

Вариант №1 (не совсем удачный, как было отмечено в комментариях).

//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var n,i,m:integer;
flag:boolean;

begin
  readln(n);
  flag:=false;
  if (n mod 2<>0)then i:=n-1 else i:=n;
  while i>0 do begin  
    if power(2,i)<=n then begin<br>      write(power(2,i),' '); flag:=true;
    end;
    i:=i-2;
end;
if not flag then writeln(0);
end.

Тест №1
1025
1024 256 64 16 4

Тест №2
1
0

Вариант №2

var a,i,n: integer;
begin
  a:=1;readln(n);
  i:=trunc(log2(n)); //получим степень двойки для n
  //если i нечетное,
  //то первое искомое число получаем путем сдвига влево на i-1 в
  //двоичном представлении числа иначе сдвиг на i
  if (i mod 2)=1 then a:=a shl(i-1) else a:=a shl i;
  //далее получаем числа сдвигая вправо на 2 разряда
  //в двоичном представлении числа
  while a>=2 do begin
    write(a,' ');
    a:=a shr 2;
  end;
end.

Тестовое решение:
2147483647
1073741824 268435456 67108864 16777216 4194304 1048576 262144 65536 16384 4096 1024 256 64 16 4





(13.9k баллов)
0

Линейка для такой задачи? Введите 2147483647

0

И очень глупо возводить 2 в N-ную степень

0

Теперь работает

0

a:=a shl (i-i mod 2); можно записать так

0 голосов

Var
  n: integer;
procedure p(i: integer);
begin
  if (i shr 30 = 0) and (i shl 2 <= n) then p(i shl 2);<br>  p(i shl 2);
  write(i, ' ')
end;
begin
  read(n);
  if n < 4 then write(0)
  else p(4)
end.

(13.3k баллов)
0

Глупо, согласен, но работает. А ваш код дает вот это: Ошибка времени выполнения: StackOverflowException: Программа завершена из-за переполнения программного стека

0

Просто забыл убрать одну строчку

0

p(i shl 2); надо убрать и все работает