Программирование на C++ Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000).<br> Входные данные Вводится натуральное число x. Выходные данные Выведите наименьший делитель числа x, отличный от 1.
#include int main() { int n; std::cin >> n; int i = 2; while (n % i > 0) ++i; std::cout << i;<br>return 0; }