Написать программу которая подтверждает числа полиморфы

0 голосов
62 просмотров

Написать программу которая подтверждает числа полиморфы


Информатика (17 баллов) | 62 просмотров
0

а поточнее что именно и как она там должна подтверждать?

0

К примеру пишешь 111 тебе выводит правильно , пишешь 1587 выводить ложь или неправильно . Понял?

0

Числа полиморфы читаются с конца также как и с начала

0

так превратить в строки и проверить на реверси

0

Спасибо, но сможешь сделать программу с таким же смыслом но чтобы в программе обязательно был оператор while P.S Не обязательно если нет времени можешь не делать

0

Всё я сам смог ...

0

program mmm; var x, x1, y, a : integer; begin Write('Введите число = '); ReadLn(X); x1:=x; while x<>0 do begin a:=x mod 10; {последняя цифра числа х} y:=y*10+a; {собираем перевернутое число} x:=x div 10; {отбрасываем последнюю цифру} end; If x1=y then WriteLn('Да') else WriteLn('Нет'); end.

Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.1 сборка 1200
begin
  var n := ReadInteger('n =');
  if n < 0 then begin
    writeln('Число отризательное и не может быть перевертышем');
    Halt;
  end;
 
  var s := n.ToString();
  if ReverseString(s) = s then
    writeln('Перевертыш')
  else  writeln('Не перевертыш');
end.

(53.1k баллов)