Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа. паскаль
Var n, s: integer; begin write('Число: '); readln(n); s := 0; while n > 0 do begin s := s + n mod 10; n := n div 10 end; writeln('Сумма цифр = ', s); end. Тестовое решение: Число: 12345 Сумма цифр = 15
На Java http://pastebin.com/SbfSZLFK ввод - 1234567890123456 вывод - 66 var n, sum: integer; begin readln(n); sum := 0; while n > 0 do begin sum := sum + n mod 10; n := n div 10 end; writeln(sum); end.