Написать программу, запрашивающая 3 целых числа и выводящая ** экран сумму этих чисел,...

0 голосов
41 просмотров

Написать программу, запрашивающая 3 целых числа и выводящая на экран сумму этих чисел, если максимум этих чисел больше 12.


Информатика (54 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Нам не обязательно находить максимум чтобы выполнить условие
//Pascal ABC.NET v3.1 сборка 1172

//Продвинутый уровень
begin
 var seq:=ReadArrInteger(3);
 if seq.any(x -> x>12)=true then writeln(seq.Sum) else writeln('Нет')
end.

//"Школьный" уровень
Var
 a,b,c:integer;
begin
 read(a,b,c);
 if (a>12) or (b>12) or (c>12) then writeln(a+b+c) else writeln('Нет');
end.

Пример ввода:
1
1
13
Пример вывода:
15

(38.6k баллов)