Помогите составить программу 1. нужна программа ** тему Алгоритма Евклида, составьте...

0 голосов
42 просмотров

Помогите составить программу
1. нужна программа на тему Алгоритма Евклида, составьте пожалуйста,чтобы в паскаль её забить.
Программа для нахождения наибольшего общего делителя.


Информатика (258 баллов) | 42 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET v3.1 сборка 1172

var
  a, b, nod: integer;

begin
  read(a, b);
  while a * b <> 0 do
    if a > b then a := a mod b
    else b := b mod a;
  nod := a + b;
  writeln(nod);
end.

Пример ввода:
1071
462
Пример вывода:
21


(38.6k баллов)