Кому не сложно помочь с PascalABC? Дана строка. Некоторые из слов взяты в круглые скобки....

0 голосов
102 просмотров

Кому не сложно помочь с PascalABC?
Дана строка. Некоторые из слов взяты в круглые скобки. Написать программу, выводящую исходную строку без скобок.


Информатика (2.7k баллов) | 102 просмотров
0

Может не просто без скобок, а без слов заключённых в скобки?

0

нет,именно без скобок,слова должны остаться

0

тогда это какая то элементарщина

Дан 1 ответ
0 голосов

Var S : String;
Begin
  Readln(S);
  While Pos('(',S)>0 do Delete(S,Pos('(',S),1);
  While Pos(')',S)>0 do Delete(S,Pos(')',S),1);
  Writeln(S);
end.

(5.1k баллов)
0

спасибо!