Написать программу которая содержит подпрограмму-функцию которая вычисляет кол-во...

0 голосов
63 просмотров

Написать программу которая содержит подпрограмму-функцию которая вычисляет кол-во положительных элементов одномерного массива 10 компонентов вещественного типа.
(РЕШИТЬ НА БАЗЕ PASCAL 7.0)


Информатика (1.8k баллов) | 63 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const
  n = 10;

type
  ty = array[1..n] of real;

var
  ar: ty;
  i: integer;

function re(ar: ty): integer;
var
  i, k: integer;
begin
  k := 0;
  for i := 1 to n do
    if ar[i] > 0 then inc(k);
  re := k;
end;

begin
  for i := 1 to n do
    readln(ar[i]);
  writeln(re(ar));
end.

Пример ввода:
-1
0
1
1
1
1
1
1
1
-2
Пример вывода:
7

(38.6k баллов)
0 голосов

Type tMas = array[1..10] of Real;
Var m : tMas;
  i : Byte;
Function OddFunc(b : tMas) : Byte;
Var j,n : Byte;
Begin
  n:=0;
  For j:=1 to 10 do If b[j]>0 then Inc(n);
  OddFunc:=n;
end;
Begin
  For i:=1 to 10 do
  Begin
    m[i]:=-100+Random(200);
    Write(m[i],' ');
  end;
  Writeln;
  Writeln(OddFunc(m));
end.

(5.1k баллов)