Составить программу для c++ "Ввести возраст человека и вывести его вместе со словом...

0 голосов
102 просмотров

Составить программу для c++ "Ввести возраст человека и вывести его вместе со словом ГОД,ГОДА,ЛЕТ(пример вам 1 год,вам 2 года,вам 55 лет)


Информатика (73 баллов) | 102 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
int main()
{
    using namespace std;
    system("chcp 1251 > nul"); //для кириллицы
    int age;
    cout << "Введите возраст: ";<br>    cin >> age;
    if (age > 4 && age < 21)
         cout << age << " ЛЕТ" << endl;<br>    else if (age % 10 == 1)
        cout << age << " ГОД" << endl;<br>    else if (age % 10 > 1 && age % 10 < 5)
        cout << age << " ГОДА" << endl;<br>    else
        cout << age << " ЛЕТ" << endl;<br>    return 0;
}

(1.1k баллов)