Написать программу, которая выводит пример ** вычитание (в пределах 100), запрашивает...

0 голосов
129 просмотров

Написать программу, которая выводит пример на вычитание (в пределах 100), запрашивает ответ пользователя, проверяет его и выводит сообщение "Правильно!" или "Вы ошиблись" и правильный результат.

program ProgramXY;
const n=100;
var inputText : integer;
begin Randomize;
var x := Random(n) + 1;
var y := Random(n) + 1;
var z := x - y;
writeln('Решите пример: ', x, ' - ', y, ' = ');
readln(inputText);
if inputText = z then writeln('Правильно!')
else writeln('Вы ошиблись! Правильный ответ: ', z)
end.

НАДО СДЕЛАТЬ БЛОК-СХЕМУ К ПРОГРАММЕ


Информатика (15 баллов) | 129 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Блок-схема к программе - в прилагаемом файле.


image
(194k баллов)