Составить программу для паскаля

0 голосов
45 просмотров

Составить программу для паскаля


image

Информатика (107 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
begin
  var a,b,x,fx:real;
  Write('Введите a b x: '); Read(a,b,x);
  if x>=2 then fx:=a+b*sqr(tan(x))
  else fx:=ln(abs(x/(a+b)));
  Writeln('y=',cos(fx))
end.

Тестовые решения:
Введите a b x: 3.5 2.18 4.7
y=0.486472312761788

Введите a b x: -3 8.15 0.035
y=0.275408828695224

(142k баллов)