Написать программу,которая выведет все числа кратные 3 в диапазоне от 26 до 87

0 голосов
90 просмотров

Написать программу,которая выведет все числа кратные 3 в диапазоне от 26 до 87


Информатика (166 баллов) | 90 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//Pascal ABC.NET v3.1 сборка 1172

begin
range(26,87).Where(x -> x mod 3=0).Println(',');
end.

(38.6k баллов)
0 голосов

Решение №1 (через целочисленное деление)

var a: integer;
begin
  a:=26;
  repeat
    if a mod 3 =0 then write(a:3);
    a:=a+1;
  until a >87;
end.

Решение №2 (без целочисленного деления)
Заметим, что первое число в данном диапазоне кратное 3 равно 27. Тогда каждое следуещее число на 3 больше предыдущего:

var a: integer;
begin
  a:=27;
  repeat
    write(a:3);
    a:=a+3;
  until a >87;
end.

(13.9k баллов)