Написать программу, которая запрашивает возраст и выводит сообщение (подросток или нет)....

0 голосов
167 просмотров

Написать программу, которая запрашивает возраст и выводит сообщение (подросток или нет). Будем считать возраст подростка от 11 лет до 15 лет.


Информатика (66 баллов) | 167 просмотров
Дан 1 ответ
0 голосов

Если на паскале сойдет, то лови...
Если от 11 и до 15, значит возраст должен быть >= 11, но <= 15 (больше или равно, меньше или равно), это можно сделать с помощью оператора in, допустим age будет равен 13, тогда пишем так if (age in [от..до]). И дальше можем что нибудь делать с этим. Вот код:<br>begin
var age: integer; //Создаем переменную для хранения возраста
readln(age); //Читаем возраст
if (age in [11..15]) then writeln('Подросток') else writeln('Не подросток');//Подробнее опишу
end. 

Допустим: 
Ввод: 13;
Вывод: 'Подросток'
---------------------------------
Ввод: 18
Вывод: 'Не подросток'
И так далее...
--------------------------------
Если не трудно
нажми "Спасибо" ;)

(198 баллов)
0

А подробнее код для паскаля можно, пожалуйста.

0

В смысле подробно код для паскале?

0

Будет более удобнее, для меня лично разобраться

0

Ты про in? Или что?

0

Да

0

Ну, оператор in проверяет в диапазоне ли число и возвращает булево значение. Синтаксис: число in [от..до], ну вообще он проверяет есть ли какое то значение в массиве, а вот [от..до] уже генерирует массив, с которым работает in. Допустим [1..5] сгенерирует массив: [1,2,3,4,5], а 3 in [1..5] проверит существование 3 в массиве [1..5]. Вроде такое и со строками можно проделывать, допустим 'a' in 'abc', но в этом я не уверен.

0

во, спасибо

0

in [..] еще используется в цикле foreach - foreach n:integer in [1..100] do write(n + ' '); - Выведет все числа от 100 до 1 ([..] генерирует массив в обратном порядке)