Написать программу которая получает два целых числа и находит их произведение не...

0 голосов
105 просмотров

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть
отрицательными. (надо в c++)


Информатика (17 баллов) | 105 просмотров
Дан 1 ответ
0 голосов

#include


int main(){
int a, b, i, c = 0, check = 0;

std::cout << "Введите певое значение:";<br>std::cin >> a;

std::cout << "Введите второе значение:";<br>std::cin >> b;

if(a < 0){
a*=-1;
check = 1;}

for(i = 0; i < a; i++)
if(check = 0)
c += b;
else
c -= b;
std::cout << c << " ";<br>std::cin >> b;

return 0;}

(98 баллов)