ПОМОГИТЕ ИСПРАВИТЬ КОД, ЯЗЫК СИ Напишите программу поиска максимального из четырех чисел...

0 голосов
144 просмотров

ПОМОГИТЕ ИСПРАВИТЬ КОД, ЯЗЫК СИ
Напишите программу поиска максимального из четырех чисел с использованием функции поиска большего из двух.


Скачать вложение Текст (TXT)

Информатика (678 баллов) | 144 просмотров
0

А что за ошибка?

0

скиньте текст ошибки

0

} в конце

Дан 1 ответ
0 голосов

#include
int chislo(int a, int b) {  if ( a > b ) return a;   else return b;}

int main(){    int a,b,c,d;
    printf("\n Óñëîâèå: Íàïèøèòå ïðîãðàììó ïîèñêà ìàêñèìàëüíîãî èç ÷åòûðåõ ÷èñåë ñ èñïîëüçîâàíèåì ôóíêöèè ïîèñêà áîëüøåãî èç äâóõ.");    printf("\n\t Ââåäèòå 1 ÷èñëî ->  ");    scanf("%i",&a);    printf("\n\t Ââåäèòå 2 ÷èñëî ->  ");    scanf("%i",&b);    printf("\n\t Ââåäèòå 3 ÷èñëî ->  ");    scanf("%i",&c);    printf("\n\t Ââåäèòå 4 ÷èñëî ->  ");    scanf("%i",&d);
    printf ( "max=%i\n" , chislo(chislo(chislo(a,b),c),d));
    return 0;}

(6.5k баллов)
0

если по уму, то такого рода программа должна делаться с массивом

0

Люблю сиську. Хороший язык, не то что у нас в школе Паскаль лохматят, убожество убогое.

0

Не учил C++) зато знаю C#) правда он здесь никому не нужен)

0

Да я думаю не очень сложный)

0

Не брался пока ещё за C#, но скажу, что обычный С - это самая простая штука, которую только можно придумать. И поэтому на нём очень легко писать.

0

Сработало, я не туда функцию внесла)

0

угу. В С (в отличие от Паскаля) все функции определяются только на глобальном глобальном уровне.

0

ещё забыла указать строку формата в последнем printf

0

ещё определила переменные после первого исполняемого оператора

0

так в С нельзя, нужно все переменные объявлять до первого исполняемого оператора