Написать программу, которая находит сумму элементов массива кратных 3.

0 голосов
201 просмотров

Написать программу, которая находит сумму элементов массива кратных 3.


Информатика (70 баллов) | 201 просмотров
Дан 1 ответ
0 голосов

Const n = 10;
var a:array[0..10] of integer;
  i,s:integer;
begin
  for i := 1 to n do begin
    a[i]:=random(21)-10;
    write(a[i]:4);
  end;
  writeln;
  for i := 1 to n do
    if a[i] mod 3 = 0 then s := s + a[i];
  writeln('Сумма кратных трем  ',s);
end.

Тестовое решение:
 8  -4   8  10   2   1  -7   9   2   0
Сумма кратных трем 9


(13.9k баллов)