ПОМОГИТЕ ПЛИЗ!!! СРОЧНО НАДО!!! 1. Составить программу решающую следующую задачу: дано...

0 голосов
47 просмотров

ПОМОГИТЕ ПЛИЗ!!! СРОЧНО НАДО!!!
1. Составить программу решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
2. Составить программу решающую следующую задачу: дан номер некоторого года (целое положительное число) . Определить соответствующий ему номер столетия , учитывая, что, к примеру, началом 20 столетия был 1901 год.


Информатика (566 баллов) | 47 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var n: integer;begin{задание 1}  write('число:  ');  readln(n);  n:=(n mod 100)*10 + n div 100;  writeln('новое число:  ',n);{задание 2}  write('год:  ');  readln(n);  if (n mod 100)=0 then n:=n div 100  else n:=(n div 100)+1;   writeln('номер столетия:  ',n);end.

(9.7k баллов)