Составьте программу, меняющую в слове Х все сочетания "кар" ** сочетание "акр"

0 голосов
37 просмотров

Составьте программу, меняющую в слове Х все сочетания "кар" на сочетание "акр"


Информатика (75 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

Программа во вложении.

(1.7k баллов)
0

Program asd;
Var
  n:string;
  i:integer;
Begin
  Writeln('Введите предложение');
  Readln(n);
  For i:=1 to length(n) do
    Begin
    if ((n[i]='к') or (n[i]='К')) and ((n[i+1]='а') or (n[i]='А')) and ((n[i+2]='р') or (n[i]='Р'))
      then begin
      n[i]:='а'; n[i+1]:='к';
      end;
    End;
  Writeln(n);
End.

0

Жаль, что редактировать запретили