ПАСКАЛЬПризнак существования треугольника: каждая его сторона должна быть меньше суммы...

0 голосов
44 просмотров

ПАСКАЛЬ
Признак существования треугольника: каждая его сторона должна быть меньше суммы двух других. Написать программу, которая, получив с клавиатуры значения сторон треугольника a,b,c, ответит, можно ли построить такой треугольник жили нет.


Информатика (49 баллов) | 44 просмотров
0

Видимо, попалась русская буква а в списке a,b,c

0

нет

0

там всё норм

0

Признак существования треугольника: каждая его сторона должна быть меньше суммы двух других. Написать программу, которая, получив с клавиатуры значения сторон треугольника a,b,c, ответит, можно ли построить такой треугольник жили нет.

0

вот задача может я вообше не правельнно сделала

0

Ну еще, возможо, у Вас нет ; в конце строки var

0

А то, что Вы сделали, прочитать невозможно: там одни кракозябры

0

я написала задачу можете помочь?

0

Её сто раз уже тут писали и я в том числе.

Дан 1 ответ
0 голосов
Правильный ответ

Var
  a, b, c: real;

begin
  writeln('Введите стороны треугольника');
  read(a, b, c);
  if (a + b > c) and (a + c > b) and (b + c > a) then
    writeln('Существует')
  else
    writeln('Не существует');
end.

и вообще пользуйтесь поиском, пользуйтесь поиском разумно. Потому что я нашла и немного допилила

(53.1k баллов)