Помогите пожалуйста написать программу на паскале турбо которая будет выводить все суммы числа 50 или n числа
Это как?
ну чтоб оно само считало и выводил чила 49+1,48+2,47+3 и так далие
Т.е. пары? или любые наборы чисел, дающие в сумме 50?
Можно же 47+1+1+1, 45+3+2, .... и т.п.
пары
Поздно
Var a,b,c:integer; begin writeln('введите число'); readln(a); for b:=1 to a-1 do begin writeln(a-b,' + ',b,' = ',a); end; end.