Нужно составить программу ** языке Паскаль

0 голосов
24 просмотров

Нужно составить программу на языке Паскаль


image

Информатика (15 баллов) | 24 просмотров
0

Только второе, я надеюсь?

0

в идеале нужны все))) Но буду благодарна хотя бы одному)))

Дан 1 ответ
0 голосов
Правильный ответ

1)
var a, c, x, y: real;
begin
    c := 0.75;
    a := exp(c);
    x := a * cos(a + c);
    y := sqrt(abs(x)+sqr(ln(sqr(x) + a) / ln(10)));
    writeln(y);
end.

2)
var a, x, y: real;
begin
    a := 2;
    x := ln(1.7 + exp(0.1 * ln(a)));
    if (x = 0)
    then
        y := a;
    if (x < 0)
    then
        y:= sin(a * x) / (a + x);
    if (0 < x) and (x < 3)
    then
        y := sqr(ln(a + x));
    if (x >= 3)
    then
        y := sqrt(ln(x) + sqr(a));
    writeln(y);
end.

3)
var y, c: real;
      x : integer;
begin
    c := 9.13;
    x := 2;
    for x := 2 to 7 do
    begin
        y := ln(abs(cos(c)) + ln(x + c)) / ln(10);
        writeln(y);
    end;
end.

(9.5k баллов)