Программа в паскале!!!! Вы должны своему другу 5 рублей. Вместо того, чтобы попросить вас...

0 голосов
123 просмотров

Программа в паскале!!!! Вы должны своему другу 5 рублей. Вместо того, чтобы попросить вас вернуть ему сразу весь долг, Ваш друг предлагает, чтобы вы платили ему определенную сумму еженедельно в течение 10 недель. Он просит вас уплатить ему в первую неделю 1 копейку, во вторую – 2, в третью - 4, в четвертую - 8 и т.д. Вы уже почти согласились с его предложением, но затем решаете сначала написать программу, чтобы проверить, какую сумму вам придется заплатить, если вы примете его предложение. Напишите эту программу и решите, каким способом лучше выплатить свой долг.


Информатика (228 баллов) | 123 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var S,x,i:integer;

begin
x:=1;
S:=0;
for i:=1 to 10 do begin
S:=S+x;
x:=x*2;
end;
end.

(108 баллов)
0

Припиши еще там write(S); перед последним end

0

var S,x,i:integer;

begin
x:=1;
S:=0;
for i:=1 to 10 do begin
S:=S+x;
x:=x*2;
end;
write(S div 100, ',', S mod 100,' рублей');
end.