Написать программу с использованием циклов. Задача ** картинке. P.S. Pascal.

0 голосов
40 просмотров

Написать программу с использованием циклов.
Задача на картинке.
P.S. Pascal.


image

Информатика (25 баллов) | 40 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x,a,s:real; i,n:integer;
begin
write('x = '); readln(x);
write('n = '); readln(n);
s:=0;
a:=-1;
for i:=1 to n do
 begin
 a:=-a*x;
 s:=s+a/i;
 end;
writeln('s = ',s);
end.

Пример:
x = 0.5
n = 4
s = 0.401041666666667

(194k баллов)