Нужно написать программу на языке Паскаль, которая будет убирать из строки все символы кроме цифр. Пример: входной- a3f4h5k&2 выходной:3452
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016 begin var s:=ReadlnString; s:=s.Where(d->d in ['0'..'9']).JoinIntoString(''); Writeln(s) end. Тестовое решение: a3f4h5k&2 3452
Var s:string; l,i:longint; begin read(s); l:=length(s); for i:=1 to l do if (s[i]>='0')and(s[i]<='9') then write(s[i]);<br>end.
а без OR можно как нибудь?
без понятия
можно наверное
но я не настолько хорошо стринг знаю
там блин как-то диапозон можно выставить, а я забыл как =)
if (s[i] >= '0') and (s[i] <= '9')<br>По стандарту языка, вроде как, цифры должны идти по порядку
да, ты прав
А где удаление символов из строки, как в задании написано?
там смотри условие, если данный символ число то печатать его крч =)