Напишите программу, которая вводит натуральные числа a и b и выводит сумму квадратов...

0 голосов
418 просмотров

Напишите программу, которая вводит натуральные числа a и b и выводит сумму квадратов натуральных чисел в диапазоне от а до b.


Что не так,как исправить?


image

Информатика (12 баллов) | 418 просмотров
Дан 1 ответ
0 голосов

Надо после do написать begin
А после writeln(k); пиши end;
Когда указывают больше двух действий надо оборачивать в begin и end.

(98 баллов)
0

не получилось,такая же ошибка...

0

Напиши код.

0

А вообще попробуй k:=k+1^2 написать в скобках
т.е. (k:=k+1^2)

0

program qq; 
var
 n,m,k,i,l,a,b:longint;
begin
 readln(a,b);
 for i:=a to b do begin (k:=k+i^2);
 writeln(k);
 end;
end.

0

Извини, я вообще без понятия

0

да ничего

0

а зачем ты ввёл столько переменных

0

k:=k+i^2 вместо этого попробуй k:=k+sqr(i)