Напишите программу, которая вычисляет сумму всех отрицательных чисел от 1 до n. Если...

0 голосов
40 просмотров

Напишите программу, которая вычисляет сумму всех отрицательных чисел от 1 до n.

Если можно побыстрее, а то на завтра нужно.


Информатика (184 баллов) | 40 просмотров
0

1 - это положительное число

0

Или Вам от -1 надо?

0

От -1

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  Writeln('s=',Range(ReadInteger('n='),-1).Sum)
end.

Тестовое решение:
n= -8
s=-36

"Школьный вариант"

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
var
  i,n,s:integer;
begin
  s:=0;
  Write('n='); Read(n);
  for i:=-1 downto n do s:=s+i;
  Writeln('s=',s)
end.

(142k баллов)
0

Ок*

0

Это потому, что Вы не знаете, как можно писать короткие программы)))

0

Не учат в школах этому. Обычно потому, что учителя сами этого не знают.

0

Ясно

0

Спасибо)))

0

Я могу Вам написать еще и сугубо школьный вариант. Если надо

0

Будет длинно и противно))

0

Ну если можно то напишите

0

Спасибо за предоставленную мне помощь.

0

Пожалуйста