Напишите программу для решения следующей задачи. ** контрольной работе по алгебре...

0 голосов
392 просмотров

Напишите программу для решения следующей задачи.
На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO.

Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.
(Pascal)
Входные данные 4
3
9
2
8
Выходные данные
2
NO


Информатика (34 баллов) | 392 просмотров
Дан 1 ответ
0 голосов

Var n,a,i,k:integer;
s:string;
begin
  s:='No'; k:=0;
  readln(n);
  for i:=1 to n do begin
    readln(a);
    if a<5 then k:=k+1;<br>    if a=10 then s:='Yes';
  end;
  writeln(k);
  writeln(s);
end.


(13.9k баллов)