Написать программу Паскаль. Дан символ и код. Найти квадрат суммы кодов этих символов.

0 голосов
69 просмотров

Написать программу Паскаль.
Дан символ и код. Найти квадрат суммы кодов этих символов.


Информатика (1.4k баллов) | 69 просмотров
0

В условии сказано "Дан символ" (один). А найти нужно "квадрат суммы кодов ЭТИХ символов". А какой второй?

0

В условии так и сказано. Наверно второй символ - это и есть код.

Дан 1 ответ
0 голосов
Правильный ответ

Может быть, имеется в виду вот это:
var c:char; k,s:integer;
begin
write('Символ = '); readln(c);
write('Код = '); readln(k);
s:=sqr(ord(c)+k);
writeln('Квадрат суммы = ',s);
end.

Пример:
Символ = A
Код = 70
Квадрат суммы = 18225

(194k баллов)
0

Да, походу так и должно быть.