Помогите, нужно в системе паскаль написать программу которая запрашивает 5 чисел и...

0 голосов
47 просмотров

Помогите, нужно в системе паскаль написать программу которая запрашивает 5 чисел и сообщает каких больше-положительных или отрицательных


Информатика (669 баллов) | 47 просмотров
0

вы циклы проходили?

Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,bz,sz: integer;
begin
b:=0;
bz:=0;
sz:=0;
while (b<5) do begin<br>write('введите число ==> ');
readln(a);
if (a>0) then bz:=bz+1;
if (a<0) then sz:=sz+1;<br>b:=b+1; 
end;
if  bz>sz then writeln('больше положительных');
if sz>bz then writeln('больше отрицательных');
if sz=bz then writeln('число отрицательных и положительных одинаково');
end.

(8.6k баллов)