Паскаль. f(x)= -3х^2-x^2-x, если х<=-2 или 2х^2-3х, если х>-2
нужно составить программу, помогите, пожалуйста.
Program Funct;
Uses Crt;
var x,rez:real;
begin
clrscr;
write('Введите x:');
readln(x);
if (x<=-2) then rez:=-3*(x*x)-(x*x)-x</p>
else rez:=2*(x*x)-3*x;
writeln('f(x)=',rez:5:5);
readkey;
end.