Написать программу, вычисляющую значение функции: y = cosx+cos2x+cos3x+…+cos30x

0 голосов
104 просмотров

Написать программу, вычисляющую значение функции:
y = cosx+cos2x+cos3x+…+cos30x


Информатика (29 баллов) | 104 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
  var x:=ReadReal('x=');
  Writeln(Range(1,30).Select(i->cos(x*i)).Sum)
end.

Тестовое решение:
x= 0.385
-2.41774673342197

(142k баллов)
0 голосов

//Pascal ABC.NET v3.1 сборка 1172

Var
 y,x:real;
 i:integer;
begin
 readln(x);
 for i:=1 to 30 do
 y:=y+cos(x*i);
 writeln(y);
end.

Пример ввода:
1
Пример вывода:
-1.32716415333901

(38.6k баллов)