Помогите с программированием в Паскале :напишите программу, которая считывает с...

0 голосов
64 просмотров

Помогите с программированием в Паскале :напишите программу, которая считывает с клавиатуры
1) количество четных чисел
2)кол-во нечетных чисел
3)кол-во считанных букв
4)кол-во гласных
5)кол-во согласных


Информатика | 64 просмотров
0

буквы русские или английские?

0

Просто считывает пять целых и все?

Дано ответов: 2
0 голосов
Правильный ответ

Написал примерный код, дорабатывайте
возможно много вариантов

(481 баллов)
0 голосов

Program q1q;
const ds=['а','е','и','о','у','ы','э','ю','я','А','Е','И','О','У','Ы','Э','Ю','Я'];
 var i,r1: integer;
     s: string;
begin
 ReadLn(s);
  r1:=0;
   for i:=1 to length(S) do if s[i] in ds then inc(r1);
  writeLn(r1); 
end. 

это про гласные, нет времени больше, простите.

(436 баллов)