Написать программу которая формирует случайным образом массив из 20 целых чисел лежащих в...

0 голосов
51 просмотров

Написать программу которая формирует случайным образом массив из 20 целых чисел лежащих в диапазоне от 0 до 1000 после чего на экран выводится сам массив в одну строку следующей строке номер максимального элемента пробел максимальный элемент


Информатика (19 баллов) | 51 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Так уже решал такую задачу:
const n=20;
var
  a:array[1..n] of integer;
  i,max,nmax:integer;
begin
  max:=0;
  for i:=1 to n do begin
    a[i]:=random(1001);
    if a[i] >max then begin
      nmax:=i;
      max:=a[i];
    end;
    write(a[i]:5);
  end;
  writeln;
  writeln(nmax,' ',a[nmax]);
end.

(13.9k баллов)