Написать программу которая формирует случайным образом массив из 20 целых чисел лежащих в...

0 голосов
121 просмотров

Написать программу которая формирует случайным образом массив из 20 целых чисел лежащих в диапазоне от 0 до 1000 после чего на экран выводится количество чисел оканчивающихся на 4


Информатика (19 баллов) | 121 просмотров
Дан 1 ответ
0 голосов

И такую задачу уже решал:
const n=20;
var
  a:array[1..n] of integer;
  i,s:integer;
begin
  s:=0;
  for i:=1 to n do begin
    a[i]:=random(1001);
    if a[i] mod 10 = 4 then s:=s+1;
  end;
  writeln(s);
end.

(13.9k баллов)
0

В начале программы после begin нужно включить генератор Randomize

0

А без включения этой строки программа не работает?

0

программа работает, только будет один и тот же набор случайных чисел, извините за азпоздалый ответ, редко здесь бываю